Phone System - Degraded Performance
Incident Report for CSG Forte
Resolved
This incident has been resolved.
Posted Jan 27, 2020 - 14:04 PST
Identified
Our local phone numbers are currently experiencing degraded performance. We are investigating this incident with our vendor. We will provide an update to the status as soon as it is available. If you have a customer service related request you can call us at 866-290-5400 Opt 1 or email customerservice@forte.net. We apologize for any inconvenience this may cause.
Posted Jan 27, 2020 - 13:29 PST
This incident affected: Support Services (Support Services).