First Data and Wells Fargo Timeouts
Incident Report for CSG Forte
Resolved
The incident was resolved last night at approximately 10:20 PM CST.
Posted Feb 27, 2020 - 03:58 PST
Investigating
We are currently investigating an incident related to authorization timeouts for First Data and Wells Fargo. We are working with our vendor to identify the issue and work toward a resolution. We will provide more details related to this incident as they become available.
Posted Feb 26, 2020 - 19:26 PST
This incident affected: Authorization Vendors (First Data).