Phone System Outage
Incident Report for CSG Forte
Resolved
Our phone system is now fully operational. We apologize for any inconvenience this may have called. Please contact our Customer Support Team at 866-290-5400 or customerservice@forte.net if you have any further questions or concerns.
Posted Sep 09, 2019 - 16:00 PDT
Investigating
Our phone system is currently experiencing degraded performance. We are investigating this incident with our vendor. We will provide an update to the status as soon as it is available. If you have a customer service related request you can email customerservice@forte.net. We apologize for any inconvenience this may cause.
Posted Sep 09, 2019 - 15:45 PDT
This incident affected: Support Services (Support Services).