First Data Timeouts
Incident Report for Forte
Resolved
This incident has been resolved.
Posted Oct 09, 2019 - 08:42 PDT
Investigating
We are currently investigating an event related to authorization time outs for First Data this morning that is causing transactions to decline. As we receive information, we will update the status.
Posted Oct 09, 2019 - 06:49 PDT
This incident affected: Authorization Vendors (First Data).