CC Settlement Delay
Incident Report for CSG Forte
Resolved
This incident has been resolved and impacted transactions have been settled. If you have questions related to this please contact our Support Team at customerservice@forte.net.
Posted Oct 20, 2020 - 06:40 PDT
Investigating
We are currently investigating a settlement delay that may affect some merchants for credit card transactions that failed to settle yesterday on 10/18/2020. We are actively working to resolve this issue. We will provide updates to the status as they are available. If you have customer service related requests, they can be emailed to customerservice@forte.net.
Posted Oct 19, 2020 - 08:58 PDT
This incident affected: Support Services (Support Services) and Authorization Vendors (Vantiv).