Phone System Experiencing Degraded Performance
Incident Report for CSG Forte
Resolved
This incident has been resolved
Posted Dec 19, 2019 - 05:56 PST
Investigating
Incoming calls are experiencing disruption which is causing connectivity issues. We are working with our vendor to resolve this issue. Please email customerservice@forte.net for assistance in the interim.
Posted Dec 19, 2019 - 05:37 PST
This incident affected: Support Services (Support Services).