CC Settlement Delay
Incident Report for CSG Forte
Resolved
This incident has been resolved.
Posted Nov 19, 2019 - 14:49 PST
Investigating
We are currently investigating a settlement delay that may affect some merchants for credit card transactions processed yesterday. We are actively working to resolve this issue. This incident will be updated when more information is available.
Posted Nov 19, 2019 - 13:02 PST
This incident affected: Support Services (Support Services) and Authorization Vendors (First Data).