Phone System - Degraded Performance

Incident Report for CSG Forte

Resolved

The root cause has been identified. Teams are engaged with the responsible third-party vendor and expect a permanent resolution soon. We are closing out this incident due to the existence of the workaround, which will remain in place.
Posted Feb 16, 2026 - 18:48 PST

Identified

A work around has been implemented and calls are now able to route to agents.  We will update once our regular service has been restored.
Posted Feb 16, 2026 - 10:18 PST

Update

We are continuing to investigate this issue.
Posted Feb 16, 2026 - 09:01 PST

Investigating

We are currently experiencing an issue impacting our external service desk phone lines. Customers are unable to reach us by phone at this time. You can still contact us via email at customerservice@forte.net for any Customer Support related requests or integration@forte.net for any Technical Support needs. Thank you!
Posted Feb 16, 2026 - 08:02 PST
This incident affected: Support Services (Support Services Phone System).