Delayed Returns for May 22nd - 23rd
Incident Report for CSG Forte
Resolved
This incident has been resolved and all impacted returns have been posted. If you have any questions related to this please contact customerservice@forte.net.
Posted May 24, 2019 - 09:00 PDT
Identified
We have identified a delay in receiving ACH return items from one of our banking partners for returns from May 22nd and 23rd. These returns will be posted by tomorrow morning. We apologize for any inconvenience this may have caused. You may contact our Customer Support Team for any further questions at 866-290-5400 Opt. 1.
Posted May 23, 2019 - 11:58 PDT
This incident affected: Settlement and Funding (ACH Funding).