Delayed ACH Returns
Incident Report for CSG Forte
Resolved
This incident has been resolved. We have worked with our banking partners and taken the necessary steps to resolve this issue. We apologize for any inconvenience this may have caused. You may contact our Customer Support Team for any further questions at 866-290-5400 Opt. 1.
Posted May 16, 2019 - 14:02 PDT
Update
We are still working with our banking partner to fully resolve the delayed returns. We apologize for any inconvenience this may have caused. We will follow up with additional information as it becomes available.
Posted May 16, 2019 - 08:48 PDT
Identified
We have identified a delay in receiving ACH return items from one of our banking partners for transactions originated in the first week of May. We are assessing the impact with our banking partner and seeking additional information for incident resolution. We will update this status with more information as it becomes available.
Posted May 14, 2019 - 10:49 PDT
This incident affected: Settlement and Funding (ACH Funding).