Funding Delay for some Split-fund merchants
Incident Report for CSG Forte
Resolved
This incident has been resolved. The funding for 6/3 was sent out last night and should be effective in the bank account today. We apologize for any inconvenience this may have caused and you may contact our Support Team at 866-290-5400 Opt 1 if you have any further questions.
Posted Jun 13, 2019 - 05:41 PDT
Investigating
We are currently investigating a funding delay affecting credit card funding from June 3, 2019 that may have impacted some merchants setup on a Split Fund model. We apologize for any inconvenience this may have caused. We will follow up with additional information as it becomes available.
Posted Jun 12, 2019 - 11:14 PDT
This incident affected: Settlement and Funding (ACH Funding).