Phone System Degraded Performance
Incident Report for Forte
Resolved
This incident has been resolved.
Posted Dec 23, 2019 - 14:47 PST
Investigating
Incoming calls are experiencing disruption which is causing connectivity issues. We are working with our vendor to resolve this issue. Please email customerservice@forte.net for assistance in the interim.
Posted Dec 23, 2019 - 14:35 PST
This incident affected: Support Services.