IVR Toll-Free Number Down
Incident Report for CSG Forte
Resolved
This issue has been resolved, callers can now use the toll free number to make payments via the IVR.
Posted May 23, 2019 - 07:12 PDT
Investigating
Our vendor is currently experiencing an issue with the IVR toll free number. In the interim callers can dial 469-795-3000 to make payments via IVR. We will update this status with more information as it becomes available.
Posted May 23, 2019 - 05:59 PDT
This incident affected: Products (IVR Payment System).