Service Fee Merchants - Visa Debit Issue
Incident Report for CSG Forte
Resolved
The issue related to Visa debit cards has been identified and resolved. We have taken measures to help prevent this issue from occurring in the future. We apologize for any inconvenience this may have caused. Please contact our Customer Support Team at customerservice@forte.net if you have any further questions or concerns.
Posted May 05, 2021 - 11:22 PDT
Investigating
We are currently investigating an issue that may be impacting some customers related to Visa debit transactions. Some Visa debit transactions are being declined or being charged an incorrect service fee. We apologize for any inconvenience and will update this status as we have additional details.
Posted May 05, 2021 - 10:41 PDT
This incident affected: Support Services (Support Services).