Connectivity Issues Impacting Multiple Products

Incident Report for CSG Forte

Resolved

All services have been fully resolved.
Posted Oct 20, 2025 - 17:46 PDT

Update

BillPay services have been restored at this time. We are still seeing multiple services with degradation as a result of today's outage. Will continue to provide updates as they become available.
Posted Oct 20, 2025 - 13:50 PDT

Investigating

CSG Forte is continuing to experience service degradation across our platforms as a result of today's outage with our public cloud provider. BillPay websites are down and our REST API platform is experiencing connectivity issues. Additionally, daily reports cannot be generated and sent out. We will provide updates from our provider as they become available.
Posted Oct 20, 2025 - 11:04 PDT
This incident affected: APIs (REST Web Services), Reporting & Notifications (Custom Activity Files), and Products (Bill pay - Online payments).