Phone System & Network Outage in Allen Office
Incident Report for Forte
Resolved
Our phone system and network services are now fully operational. We apologize for any inconvenience this may have called. Please contact our Customer Support Team at 866-290-5400 or customerservice@forte.net if you have any further questions or concerns.
Posted Aug 23, 2019 - 07:26 PDT
Investigating
Our phone system and network services are currently experiencing degraded performance. We are investigating this incident with our vendor. There is no impact to transaction processing or our related products and solutions. We will provide updates to the status as they are available. If you have customer service related request they can be emailed to customerservice@forte.net and will be addressed as soon as we are back in an operational state.
Posted Aug 23, 2019 - 05:41 PDT
This incident affected: Support Services.