Delayed Invoice Delivery
Incident Report for CSG Forte
Resolved
We have identified the issue that caused delayed delivery of merchant invoices and have resolved the matter. Invoices will generate this evening and will be emailed to merchants tomorrow.
Posted Oct 08, 2019 - 14:13 PDT
Investigating
We are currently researching an issue related to the delayed delivery of Merchant Invoices. As we receive information we will update this status.
Posted Oct 07, 2019 - 11:17 PDT
This incident affected: Support Services (Support Services).