Delayed Chargeback Disputes Delivery
Incident Report for CSG Forte
Resolved
All disputes have now been processed. We apologize for the delay. Please contact our Customer Support Team at 866-290-5400 or customerservice@forte.net if you have any further questions or concerns.
Posted Aug 14, 2019 - 13:57 PDT
Investigating
We are currently researching an issue related to the delayed delivery of our disputes chargeback file. As we receive information we will update this status.
Posted Aug 14, 2019 - 10:59 PDT
This incident affected: Support Services (Support Services).